Errors logging into Impilo Platform

Incident Report for Impilo Health

Resolved

This incident has been resolved. Thank you for your patience.
Posted Oct 20, 2025 - 22:22 EDT

Update

Our authentication partner has confirmed their outage and is working on remediation.
Posted Oct 20, 2025 - 15:28 EDT

Investigating

We are investigating issues with our platform login page. We have reached out to our authentication vendor for assistance.
Posted Oct 20, 2025 - 15:09 EDT
This incident affected: Platform (Portal (app.impiloplatform.com)).