As of now, we believe all of the missing readings across all four affected data types from the previous weekend (on 11/15 and 11/16) have been backfilled by Transtek into Impilo.
During the course of this backfill, we received many duplicates of the readings from 11-15 through 11-21. In some cases, this resulted in duplicate or very delayed alerts based on the readings. Where possible, we were able to delete these duplicate alerts if they were not linked to a support ticket, clinical note, or a manual review status.
Transtek notified us this morning that they have added protection against the delivery of duplicate data to Impilo going forward. Additionally, Impilo today also deployed changes to our reading processing pipelines to prevent the processing of identical data from Transtek should they deliver it.
We believe this incident is now resolved. We appreciate your patience as we worked through this issue.
Posted Nov 21, 2025 - 17:27 EST
Update
We have marked the duplicate blood pressure, blood oxygen, weight, and blood glucose readings as deleted (hidden from view and calculation) in our platform.
Additionally, we are developing changes to our reading ingestion pipelines to detect duplicates before they are recorded which we hope to deploy in the coming days after sufficient testing.
We continue to await a full backfill of reading data from the weekend.
Posted Nov 19, 2025 - 23:10 EST
Update
We have determined that the far-future date issue also affected Weight scales, Glucometers, and Blood Oxygen readings. The date issue has been resolved for all of these data types.
Data from the outage continues to backfill as it is delivered to us by Transtek. They have estimated that our full data backfill will complete by the night of November 20th.
During the course of this backfill, we have received some duplicate readings from the past few days. These will be removed once backfilling has completed. However, these have been delivered to customer webhook endpoints already.
Posted Nov 18, 2025 - 18:12 EST
Monitoring
All of the webhooks which were affected by the far-future date issue have been re-sent to their destinations. We are awaiting word on the status of a data backfill from the weekend.
All new readings are being processed as normal.
Posted Nov 17, 2025 - 17:32 EST
Update
We have corrected the dates from the far future for all mis-processed readings. We have reprocessed all billing cycles and claims for patients who had those readings processed in that manner. We continue to investigate the backfill progress for the readings from the previous day.
Posted Nov 17, 2025 - 14:20 EST
Identified
We have deployed a hotfix for issues with dates in the far future and recalculated those dates for recently processed readings. We are continuing to investigate backfilling data from the weekend and issues with billing reports.
Posted Nov 17, 2025 - 11:37 EST
Update
We are in contact with Transtek about this issue. Customers may see dates in the far future for blood pressure readings taken in the past two days. We continue to work on resolution.
Posted Nov 17, 2025 - 11:14 EST
Investigating
We are investigating issues with blood pressure readings from Transtek BP devices. Customers may have errors viewing readings or generating billing reports for patients who have taken readings since Saturday morning, November 15th.
Posted Nov 17, 2025 - 10:55 EST
This incident affected: Platform (Portal (app.impiloplatform.com), Readings).