Reading Processing Delays

Incident Report for Impilo Health

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:29 EDT

Monitoring

Our queue of incoming readings has been processed and new readings are being handled in realtime. We are monitoring for any residual issues.
Posted Oct 20, 2025 - 14:38 EDT

Update

We are continuing to investigate this issue, which we have confirmed is related to issues with our hosting provider.
Posted Oct 20, 2025 - 14:16 EDT

Investigating

We are investigating delays in processing readings.
Posted Oct 20, 2025 - 13:38 EDT
This incident affected: Platform (Readings).